Add webpart

Oct 25, 2011 at 7:05 PM

I have no problem to deploy the solution, when go to the page, trying to add webparts, I am getting "An error occurred while attempting to add the item to the page.

anyone has any idea?

Oct 25, 2011 at 8:36 PM

From CA -> System Settings -> Manage Farm Solutions, under Solution Management, does the peoplesearchpivot.wsp show status deployed for your web frontend?

Did you enable the site collection feature "People Search Pivot Viewer Webpart" before adding the webpart? The feature must be enabled at the site collection level of each site you with to use it on.


Oct 25, 2011 at 8:44 PM

yes, it is deployed to the webfrontend. web configure file is updated.

enabled the webpart on root of site feature.

I can see the webpart listed on custom area, but trying to add it, error out.


Oct 25, 2011 at 8:54 PM

Have you tried to Disable and then Enable the Site Feature. Also, the webpart shows up in the list regardless of it being enabled or not.

I am not sure what your topology is so bear with me: Have you tried to deploy webpart directly at the top level under the site collection that you had enabled it?

Site collection: http://Server/sitecollection

From site Collection features: http://server/sitecollection/_layouts/ManageFeatures.aspx?Scope=Site

Page to deploy Webpart http://Server/sitecollection/peoplesearch.aspx

I am only asking this because I have a toplogy that reaches 3 and sometimes 4 collections deep, which means if I enable feature at http://Server/sitecollection the feature will not work at http://server/sitecollection/sitecollection1

If this does not work you may need to try to redeploy solution. Hope this is helpful.